firefox

Sous la majorité des distributions GNU/Linux, les logiciels s'installent depuis les dépôts. Ce sont des serveurs où les logiciels sont "pré-formatés" pour la distribution que l'on utilise et où le système vient télécharger les dernières mises à jour.
Ainsi, quand par exemple sort une nouvelle version de Firefox, elle est disponible très rapidement dans les dépôts et dés lors disponible automatiquement via les mises à jours du système.

C'est pas le cas sous Ubuntu. Canonical a décidé que si la version d'Ubuntu contenait Firefox 3.5 à sa sortie, alors elle aura toujours Firefox-3.5, et uniquement des mises à jour de la 3.5. Donc, on aura bien la 3.5.1, ou la 3.5.2 mais pas de 3.6.

Je trouve ça chiant. Non seulement, on n'a pas par défaut la toute dernière version d'un logiciel, mais en plus, parfois, ce sont des failles de sécurités qui restent là.

Récemment, Firefox 3.6.4 est sortie et avec elle la séparation de Flash dans un processus différent (vous pouvez pas savoir combien j'attendais ça). Ben ça fait une semaine que Firefox 3.6.4 est sortie et toujours pas mis à jour dans les dépôts. Merde quoi !
Bien-sûr, on peut quand même l'installer, mais que ce ne soit pas proposée en mise à jour par défaut, c'est chiant.

Il suffit juste d'ajouter les dépôts "mozilla-sécurity" :

sudo add-apt-repository ppa:ubuntu-mozilla-security/ppa
sudo aptitude update
sudo aptitude safe-upgrade

Et Firefox 3.6.4 est installée (comme le seront automatique les versions futures d'ailleurs).

Tout va donc bien… Ou presque : à l'ouverture, Firefox me signale de mettre à jour le plugin Flash car la 10.0 est dangereuse. Bon, ok… Je recherche dans les listes des paquets : rien, pas de Flash-10.1. Une recherche sur le web me dit qu'il faut ajouter le dépôt "Canonical Partner". Et, c'est reparti pour un tour :
J'ajoute la ligne deb http://archive.canonical.com/ubuntu lucid partner au fichier /etc/apt/sources.list et je fait :
sudo aptitude update
sudo aptitude install adobe-flashplugin

Bon !! On y est enfin : j'ai la dernière version de Firefox (enfin presque, car la 3.6.6 est sortie en ce jour). J'ai aussi le plugin Flash à jour.

Je trouve le système des dépôts de GNU/Linux fabuleux (et c'est peu dire), mais le fait de devoir faire le tour du web pour trouver comment mettre à jour Firefox et Flash parce que les versions sont gelés dans les dépôts, c'est quand même un scandale. Surtout quand c'est un problème de sécurité.

Merci donc à ces deux sites, pour l'aide sur Firefox et pour Flash.

Image de Gainesp2003