Depuis un moment, Adobe ne fournit plus le plugin Flash pour Ubuntu et les autres distributions GNU/Linux : la dernière version en date est la version 11.2 (alors qu’ils en sont à la version 17 actuellement).
Google propose Chrome et Chromium avec un plugin Flash intégré : c’est Google qui fournit Flash à la place d’Adobe. Ce n’est donc pas génial.

Ici je vous résume la méthode d’installation de Flash dans Ubuntu (et ses dérivés, dont Linux Mint) utilisable par Firefox. Je suis sous Mint 17, basé sur Ubuntu 14.04 et j’utilise Firefox 38.

Ma page s’inspire et regroupe ce qui est dit ici : Le meilleur de Flash sous Ubuntu et Firefox | blog@kmelia. Cette méthode ne marche pas pour Chrome et dérivés.

En pratique, tout ça va passer par un programme nommé « Pipelight » (doc), qui sert d’interface d’installation dans Linux des version Flash de Windows (Adobe fournit Flash pour Windows, mais pas pour Linux, en fait). Pipelight permet aussi d’installer Silverlight et d’autres plugins.
Pipelight est libre, mais utilise des fichiers non-libres (polices microsoft) et permet d’installer des plugins qui ne le sont pas non plus.

Installation de Pipelight

Premièrement, installons Pipelight.
On ajoute le dépôt officiel :
sudo add-apt-repository ppa:pipelight/stable
On installe les paquets qu’il faut (ça requiert pas loin de 330 Mo) :
sudo apt-get update
sudo apt-get install --install-recommends pipelight-multi
On recharge la liste des plugin :
sudo pipelight-plugin --update
On dit à Firefox de prendre en compte les plugins de Pipelight :
sudo pipelight-plugin --create-mozilla-plugins

Installons Flash via Pipelight


On supprime le paquet de Flash actuel :
sudo apt-get remove flashplugin-installer adobe-flashplugin --purge
On active le nouveau plugin :
sudo pipelight-plugin --enable flash
On supprime la liste des plugins de Firefox (il mettra à jour le fichier tout seul — ici je ne supprime pas le fichier, mais j’en garde une copie au cas où) :
mv ~/.mozilla/firefox/*.default/pluginreg.dat ~/.mozilla/firefox/old_pluginreg.dat

Normalement, tout est bon : Flash 17 (à ce jour) devrait être installé.

En relançant Firefox, vous aurez une petite fenêtre « wine-flash-installer » : elle se fermera toute seule (pas de panique) et c’est juste pour cette fois.
Quand la fenêtre est partie, vous pourrez vérifier sur cette page que la dernière version de Flash est bien installée et active dans Firefox :

version de Flash dans Firefox
Concernant les mises à jour, comme il est dit sur la page de Kmelia, il faut faire une différence entre la mise à jour de Pipelight (qui se fait avec la mise à jour du système, via Apt) et la mise à jour des plugins, qui se fait avec la commande suivante :
sudo pipelight-plugin --update

Quand vous faites une mise à jour système donc, je vous conseille de vérifier directement s’il y a une mise à jour des plugins.

12 commentaires

gravatar
JohnDoe a dit :

Dans le même goût, il y a aussi Le Fresh Wrapper pour Ubuntu, qui permet d'utiliser Pepper Player ( Flash made in Google, dispo dans Chrome ) directement dans Firefox. Par contre, je ne crois pas qu'on soit dépendant de Wine, vu que ce n'est qu'un wrapper.

Je l'ai vu il y a quelques temps, mais ne m'y suis pas encore trop attardé, à tester si quelqu'un est intéressé :)

Docs ici : webupd8 et là GitHub

gravatar
Gilles a dit :

NON.
Fuck Flash.

Désolé, moi je reste avec Flash 11.2 (qui est fourni par Adobe etmis à jour niveau sécurité, pour l'instant).
Et le jour où ça sera fini, bah... fuck Flash.

Y'a que la xubuntu du fiston qui utilise Flash pour les jeux FB que je mettrai à jour.

Tu as pas la méthode pour utiliser IE6 sous Linux aussi ?

Franchement, crève Flash.

gravatar
koloce a dit :

Il existe un plugin gnash libre qui permet de remplacer flash, malheureusement il ne lit pas toutes les vidéos/ fichiers. Un problème venant des derniers formats propriétaires.

gravatar
Tiwy57 a dit :

A noter que j'ai du tout utiliser en sudo
j'ai eu un soucis avec "pipelight-plugin --create-mozilla-plugins"

ERROR: /usr/lib/pipelight/libpipelight-silverlight5.1.so exists but unable to delete it, aborting
ERROR: are you running this program with root rights?

Et ensuite, j'ai du redémarrer firefox deux fois, l'un pour l'installation du module (la petite fenêtre wine-flash-installer), flash n'était pas detecté encore en tant que plugin.
Après second redémarrage, ça fonctionne.

gravatar
Micka a dit :

Bonjour,

Ne fonctionne pas sur pluzz.francetv.fr (par exemple)
Seul la version 11 fonctionne.

gravatar
Pierre-Yves a dit :

c'est vrai que la version 11.2 reçoit toujours les mises à jour de sécurité et vu le peu d'usage que j'en fais (lecture de vidéo), dans mon cas c'est suffisant...
par contre pour ceux qui doivent utiliser des machins fait en flex ou qui jouent à des jeux en flash, j'imagine que ce tuto peut bien dépanner ! :)

gravatar
Isys a dit :

Bonjour et, quelque part, merci pour ces infos, sauf que le plugin plante sans arrêt.

gravatar
Bat a dit :
Pipelight est devenu pourrave et provoque beaucoup de bug dans pas mal de jeux flash.....

Une autre solution plus cohérente, ce serait cool, je ne trouve rien là-dessus.

Vivement que les dev abandonnent ce langage anti-linuxien.
gravatar
Le Hollandais Volant a dit :
@Bat : la solution que j'ai retenu, c'est de virer flash totalement de l'ordi. Les dev utilisent ce que l'internaute peut prendre en compte.

Sans flash, quelques sites ne marcheront plus, mais globalement ça va.
gravatar
NS a dit :
Bonjour,
J'ai le même problème et impossible de passer la première étape. Je crois que le dépot officiel n'est pas installé mais quand j'essaye, ça ne fonctionne pas et c'est vraiment embêtant... Que dois-je faire? Pouvez-vous m'aider svp?

Les commentaires sont fermés pour cet article