Dans Ubuntu 10.10, je ne sais pas, mais dans Linux Mint 10 les dépôts officiels sont prioritaires sur les dépôts tiers.

Pour remettre tous les dépôts à égalité, et faire en sorte que le numéro de version compte plus au lieu de la source :

sudo mv /etc/apt/preferences /etc/apt/preferences.BAK

Exemple avec le navigateur Opera : les sources de Mint proposent actuellement la version 10.62. Opera propose la version officielle 10.63. Or, si on ajoute le dépôt et la clé, Opera ne sera pas mis à jour car c'est la version de Linux Mint qui sera prioritaire.

Même chose pour Virtual Box, Wine et tous les autres.

En soit c'est sécuritaire : l'ajout de PPA à gogo est un risque de sécurité, et on ne devrait toujours faire que confiance aux dépôts officiels, mais quand ces derniers ne sont jamais à jours (et c'est toujours le cas, malheureusement) il est nécessaire d'ajouter un dépôt tierce-partie.

9 commentaires

gravatar
qwerty a dit :

je croit que les officiels sont prioritaires sous ubuntu. A confirmer !

gravatar
Bruno a dit :

Merci pour l'info, et la ligne de code! Une véritable mise-à-jour "vite faite, bien faite", ne fait pas de mal (en contrepartie, comme vous le rappelez, "d'un peu d'insécurité", bien relative).

En complément d'information, j'ai remarqué par ailleurs que, apparemment, "Linux Mint" n'était pas le seul à se baser sur les dépôts "Linux Mint": je pense en particulier au récent OS GNU/Linux "Peppermint Ice" (tout comme "Linux Mint LXDE": parfait pour un netbbook).

D'autre part, Linux Mint 10 "Julia" (à mon humble avis: "génial!") a un petit air de famille avec Pinguy OS, côté présentation...

Bref: le monde du libre est loin d'être hermétique, et c'est: "Tant mieux!"

Je vois que vous avez bon goût: et pas que pour Linux Mint, mais aussi pour Opera (même s'il n'est pas Opezn Source, ce navigateur est assez bien sécurisé...).

Ne pas oublier cependant l'existence de Chromium, open source (ne pas totalement confondre avec Google Chrome, qui n'est pas, lui, open source), Chromium donc, une véritable "bête de course", côté vitesse de téléchargement des pages web.

Cordialement

gravatar
Le Hollandais Volant a dit :

Apparemment, et d'après pas mal d'utilisateurs, le duo Opera-Mint est très apprécié !

Je me suis mis à Opera 11 (version beta) et pour le moment c'est carrément génial : il se lance aussi rapidement que Chromium et il est toujours aussi complet que opera 10.

Les très attendues "extensions" ne sont qu'au nombre de quelques dizaines, mais ça promet pour l'avenir.

Mint Julia est très beau coté "look" : le thème utilisant les icônes du pack Faenza est magnifique, même s'il y'a quelques petits bug graphiques.

gravatar
Rolinh a dit :

Pourquoi ne passes-tu pas à une distribution type rolling?

gravatar
Le Hollandais Volant a dit :

Je le voudrais en effet, mais pour ce que je connais, seul Ubuntu fournit pour le moment quelques outils dont j'ai besoin (gestion iPod touch entre autre).

Si je suis sous Linux Mint, c'est pour ça : il est basé sur Ubuntu et en possède donc la force.
J'espère que la version Debian (LMDE) intégrera des choses de la version Ubuntu pour que je puisse passer sous LMDE, et donc Debian, qui elle est en rolling release :)

gravatar
Rolinh a dit :

Je ne possède pas d'iPhone/iPod mais il me semble que la gestion de celui-ci est permise grâce à une librairie du nom de libimobiledevice.
Donc rien ne t'empêche de passer à une distribution rolling pour autant que la librairie soit dans les dépôts ;)

Personnellement, j'utilise Archlinux (et n'en démord pas :P ) et je viens de vérifier:
la librairie est dans le dépôts extras. Donc en théorie, aucun soucis pour ton iPod touch ;)

Si jamais tu veux faire le saut avant l'heure... ;)

gravatar
Rolinh a dit :

Je ne possède pas d'iPhone/iPod mais il me semble que la gestion de celui-ci est permise grâce à une librairie du nom de libimobiledevice.
Donc rien ne t'empêche de passer à une distribution rolling pour autant que la librairie soit dans les dépôts ;)

Personnellement, j'utilise Archlinux (et n'en démord pas :P ) et je viens de vérifier:
la librairie est dans le dépôts extras. Donc en théorie, aucun soucis pour ton iPod touch ;)

Si jamais tu veux faire le saut avant l'heure... ;)

gravatar
Le Hollandais Volant a dit :

Mouais, la dernière fois que j'avais essayé, c'était sous Debian (en plus de LMDE) et ça n'avais pas marché :-/

Je retenterais un de ces jours.

Les commentaires sont fermés pour cet article